const regex = new RegExp('^([0-9]+)(\\/)([0-9]+)(\\/)([0-9][0-9]) ([0-9]+):([0-9][0-9]) (a|p).\\s(m).', '')
const str = `3/10/20 2:25 p. m. - rogertovalle: Buenas tardes
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}