$re = '/^([0-9]+)(\/)([0-9]+)(\/)([0-9][0-9]) ([0-9]+):([0-9][0-9]) (a|p).\s(m)./';
$str = '3/10/20 2:25 p. m. - rogertovalle: Buenas tardes
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);