re = /(?<!(?:\\{2})*\\)(?:(?<begin_capture>[\(])(?:(?=[<][a-z_A-Z]+[>])|(?!\?(?:<?[=!]|:)))|(?<begin_non_capture>\((?=\?(?:<?[=!]|:))))|(?:(?<end>\)))/m
str = '// Basic - All standard capture groups
(?<=^[ \\t]*)(//)([ ])(?<capture_name>)(Case:)([ \\t]+)(.*\\S)([ \\t]*)?$
// Complex
(?<=^[ \\t]*)(//)([ ])(Case:)([ \\t]+)(.*\\S)([ \\t]*)?$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end