import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(?:\\\\{2})*\\\\)(?:(?<begin_capture>[\\(])(?:(?=[<][a-z_A-Z]+[>])|(?!\\?(?:<?[=!]|:)))|(?<begin_non_capture>\\((?=\\?(?:<?[=!]|:))))|(?:(?<end>\\)))";
final String string = "// Basic - All standard capture groups\n"
+ "(?<=^[ \\t]*)(//)([ ])(?<capture_name>)(Case:)([ \\t]+)(.*\\S)([ \\t]*)?$\n\n\n"
+ "// Complex\n"
+ "(?<=^[ \\t]*)(//)([ ])(Case:)([ \\t]+)(.*\\S)([ \\t]*)?$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}