const regex = /(?<!(?:\\{2})*\\)(?:(?<begin_capture>[\(])(?:(?=[<][a-z_A-Z]+[>])|(?!\?(?:<?[=!]|:)))|(?<begin_non_capture>\((?=\?(?:<?[=!]|:))))|(?:(?<end>\)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(?:\\\\{2})*\\\\)(?:(?<begin_capture>[\\(])(?:(?=[<][a-z_A-Z]+[>])|(?!\\?(?:<?[=!]|:)))|(?<begin_non_capture>\\((?=\\?(?:<?[=!]|:))))|(?:(?<end>\\)))', 'gm')
const str = `// Basic - All standard capture groups
(?<=^[ \\t]*)(//)([ ])(?<capture_name>)(Case:)([ \\t]+)(.*\\S)([ \\t]*)?\$
// Complex
(?<=^[ \\t]*)(//)([ ])(Case:)([ \\t]+)(.*\\S)([ \\t]*)?\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}