#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!(?:\\{2})*\\)(?:(?<begin_capture>[\(])(?:(?=[<][a-z_A-Z]+[>])|(?!\?(?:<?[=!]|:)))|(?<begin_non_capture>\((?=\?(?:<?[=!]|:))))|(?:(?<end>\)))"
Local $sString = "// Basic - All standard capture groups" & @CRLF & _
"(?<=^[ \t]*)(//)([ ])(?<capture_name>)(Case:)([ \t]+)(.*\S)([ \t]*)?$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// Complex" & @CRLF & _
"(?<=^[ \t]*)(//)([ ])(Case:)([ \t]+)(.*\S)([ \t]*)?$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")