$re = '/(?<=ee|i)r\b/m';
$str = 'beer
beer
beer
fir';
$subst = "yah";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;