const regex = /(?<=ee|i)r\b/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=ee|i)r\\b', 'mg')
const str = `beer
beer
beer
fir`;
const subst = `yah`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);