use strict;
my $str = 'beer
beer
beer
fir';
my $regex = qr/(?<=ee|i)r\b/mp;
my $subst = 'yah';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";