#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=ee|i)r\b"
Local $sString = "beer" & @CRLF & _
" beer" & @CRLF & _
"beer" & @CRLF & _
"fir"
Local $sSubst = "yah"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)