// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^AD(D[0-9]+)(C,(([\.0-9]+)(X([\.0-9]+))?))$").unwrap();
let string = "ADD10C,.01X.27";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}