package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^AD(D[0-9]+)(C,(([\.0-9]+)(X([\.0-9]+))?))$`)
var str = `ADD10C,.01X.27`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}