$re = '/^AD(D[0-9]+)(C,(([\.0-9]+)(X([\.0-9]+))?))$/m';
$str = 'ADD10C,.01X.27';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);