using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^AD(D[0-9]+)(C,(([\.0-9]+)(X([\.0-9]+))?))$";
string input = @"ADD10C,.01X.27";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}