$re = '/((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))/m';
$str = 'OTP for YONO transaction in SBI is 449270. Do not share it with anyone by any means. This is confidential and to be used by you only.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);