import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))";
final String string = "OTP for YONO transaction in SBI is 449270. Do not share it with anyone by any means. This is confidential and to be used by you only.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}