using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))";
string input = @"OTP for YONO transaction in SBI is 449270. Do not share it with anyone by any means. This is confidential and to be used by you only.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}