const regex = /((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))', 'gm')
const str = `OTP for YONO transaction in SBI is 449270. Do not share it with anyone by any means. This is confidential and to be used by you only.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}