// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)").unwrap();
let string = "https://instagram.com/p/aye83DjauH/?foo=bar#abc
https://www.instagram.com/reel/Chunk8-jurw/
https://www.instagram.com/p/BQ0eAlwhDrw/
https://www.instagram.com/tv/BkfuX9UB-eK/
https://instagram.com/p/-Cmh1cukG2/
http://instagram.com/p/9o6LshA7zy/embed/
https://www.instagram.com/tv/aye83DjauH/
https://www.instagram.com/reel/CDUMkliABpa/
https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}