#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)"
Local $sString = "https://instagram.com/p/aye83DjauH/?foo=bar#abc" & @CRLF & _
"https://www.instagram.com/reel/Chunk8-jurw/" & @CRLF & _
"https://www.instagram.com/p/BQ0eAlwhDrw/" & @CRLF & _
"https://www.instagram.com/tv/BkfuX9UB-eK/" & @CRLF & _
"https://instagram.com/p/-Cmh1cukG2/" & @CRLF & _
"http://instagram.com/p/9o6LshA7zy/embed/" & @CRLF & _
"https://www.instagram.com/tv/aye83DjauH/" & @CRLF & _
"https://www.instagram.com/reel/CDUMkliABpa/" & @CRLF & _
"https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")