package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)`)
var str = `https://instagram.com/p/aye83DjauH/?foo=bar#abc
https://www.instagram.com/reel/Chunk8-jurw/
https://www.instagram.com/p/BQ0eAlwhDrw/
https://www.instagram.com/tv/BkfuX9UB-eK/
https://instagram.com/p/-Cmh1cukG2/
http://instagram.com/p/9o6LshA7zy/embed/
https://www.instagram.com/tv/aye83DjauH/
https://www.instagram.com/reel/CDUMkliABpa/
https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}