re = /https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)/m
str = 'https://instagram.com/p/aye83DjauH/?foo=bar#abc
https://www.instagram.com/reel/Chunk8-jurw/
https://www.instagram.com/p/BQ0eAlwhDrw/
https://www.instagram.com/tv/BkfuX9UB-eK/
https://instagram.com/p/-Cmh1cukG2/
http://instagram.com/p/9o6LshA7zy/embed/
https://www.instagram.com/tv/aye83DjauH/
https://www.instagram.com/reel/CDUMkliABpa/
https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end