$re = '/TEMP SP nnn.nn/m';
$str = 'TEMP SP 1.00
TEMP SP 100.01
TEMP SP 1.0
TEMP SP 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);