using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TEMP SP nnn.nn";
string input = @"TEMP SP 1.00
TEMP SP 100.01
TEMP SP 1.0
TEMP SP 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}