package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TEMP SP nnn.nn`)
var str = `TEMP SP 1.00
TEMP SP 100.01
TEMP SP 1.0
TEMP SP 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}