const regex = /TEMP SP nnn.nn/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('TEMP SP nnn.nn', 'gm')
const str = `TEMP SP 1.00
TEMP SP 100.01
TEMP SP 1.0
TEMP SP 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}