// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\s+\/inference=".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)"#).unwrap();
let string = " /inference=\"blah
blah
BLAH
/codon_start=blah
/inference=\"similar
/codon_start=blah";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}