using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+\/inference="".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)";
string input = @" /inference=""blah
blah
BLAH
/codon_start=blah
/inference=""similar
/codon_start=blah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}