$re = '/(\s+\/inference=".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)/';
$str = ' /inference="blah
blah
BLAH
/codon_start=blah
/inference="similar
/codon_start=blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);