re = /(\s+\/inference=".+)\n\s+(\s+([^\/\n]+\n){1,2})(\s+\/codon_start=.+)/
str = ' /inference="blah
blah
BLAH
/codon_start=blah
/inference="similar
/codon_start=blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end