// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^https?:\/\/([^\/]+\.)?phila-homologa\.([^\/]+)\/?player\/curso\/([^w]+)$").unwrap();
let string = "https://phila-homologa.nescon.medicina.ufmg.br/player/curso/para-elas-2019/878998430";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}