re = /^https?:\/\/([^\/]+\.)?phila-homologa\.([^\/]+)\/?player\/curso\/([^w]+)$/i
str = 'https://phila-homologa.nescon.medicina.ufmg.br/player/curso/para-elas-2019/878998430'
# Print the match result
str.match(re) do |match|
puts match.to_s
end