$re = '/^https?:\/\/([^\/]+\.)?phila-homologa\.([^\/]+)\/?player\/curso\/([^w]+)$/i';
$str = 'https://phila-homologa.nescon.medicina.ufmg.br/player/curso/para-elas-2019/878998430';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);