const regex = /^https?:\/\/([^\/]+\.)?phila-homologa\.([^\/]+)\/?player\/curso\/([^w]+)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/([^\\\/]+\\.)?phila-homologa\\.([^\\\/]+)\\\/?player\\\/curso\\\/([^w]+)$', 'i')
const str = `https://phila-homologa.nescon.medicina.ufmg.br/player/curso/para-elas-2019/878998430`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}