import Foundation
let pattern = #"\.getFlag[(](?:\s*(?:\s*["'](.*)["']\s*,\s*(["'].*\s*[^"]*["']|[^)]*))\s*[)])?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Flag<String> btnColorFlag = visitor.getFlag("btnColor", "red");
Flag<Number> backgroundColorFlag = visitor.getFlag("backgroundSize", 13);
Flag<Boolean> backgroundColorFlag = visitor.getFlag("showBackground", true);
Flag<String> backgroundColorFlag = visitor.getFlag("backgroundColor", "green");
Flag<String> btnColorFlag = visitor.getFlag("btnColor", "red, red, blue");
Flag<Number> backgroundColorFlag = visitor.getFlag("backgroundSize", "(Hello world)!");
Flag<Boolean> backgroundColorFlag = visitor.getFlag("showBackground", true);
Flag<String> backgroundColorFlag = visitor.getFlag("backgroundColor", "green");
Flag<Boolean> backgroundColorFlag = visitor.getFlag(showBackground, true);
Flag<String> backgroundColorFlag = visitor.getFlag(backgroundColor, "green");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)