import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.getFlag[(](?:\\s*(?:\\s*[\"'](.*)[\"']\\s*,\\s*([\"'].*\\s*[^\"]*[\"']|[^)]*))\\s*[)])?";
final String string = " Flag<String> btnColorFlag = visitor.getFlag(\"btnColor\", \"red\");\n"
+ " Flag<Number> backgroundColorFlag = visitor.getFlag(\"backgroundSize\", 13);\n"
+ " Flag<Boolean> backgroundColorFlag = visitor.getFlag(\"showBackground\", true);\n"
+ " Flag<String> backgroundColorFlag = visitor.getFlag(\"backgroundColor\", \"green\");\n\n"
+ " Flag<String> btnColorFlag = visitor.getFlag(\"btnColor\", \"red, red, blue\");\n"
+ " Flag<Number> backgroundColorFlag = visitor.getFlag(\"backgroundSize\", \"(Hello world)!\");\n"
+ " Flag<Boolean> backgroundColorFlag = visitor.getFlag(\"showBackground\", true);\n"
+ " Flag<String> backgroundColorFlag = visitor.getFlag(\"backgroundColor\", \"green\");\n\n"
+ " Flag<Boolean> backgroundColorFlag = visitor.getFlag(showBackground, true);\n"
+ " Flag<String> backgroundColorFlag = visitor.getFlag(backgroundColor, \"green\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}