$re = '/\.getFlag[(](?:\s*(?:\s*["\'](.*)["\']\s*,\s*(["\'].*\s*[^"]*["\']|[^)]*))\s*[)])?/m';
$str = ' Flag<String> btnColorFlag = visitor.getFlag("btnColor", "red");
Flag<Number> backgroundColorFlag = visitor.getFlag("backgroundSize", 13);
Flag<Boolean> backgroundColorFlag = visitor.getFlag("showBackground", true);
Flag<String> backgroundColorFlag = visitor.getFlag("backgroundColor", "green");
Flag<String> btnColorFlag = visitor.getFlag("btnColor", "red, red, blue");
Flag<Number> backgroundColorFlag = visitor.getFlag("backgroundSize", "(Hello world)!");
Flag<Boolean> backgroundColorFlag = visitor.getFlag("showBackground", true);
Flag<String> backgroundColorFlag = visitor.getFlag("backgroundColor", "green");
Flag<Boolean> backgroundColorFlag = visitor.getFlag(showBackground, true);
Flag<String> backgroundColorFlag = visitor.getFlag(backgroundColor, "green");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);