use strict;
my $str = ' Flag<String> btnColorFlag = visitor.getFlag("btnColor", "red");
Flag<Number> backgroundColorFlag = visitor.getFlag("backgroundSize", 13);
Flag<Boolean> backgroundColorFlag = visitor.getFlag("showBackground", true);
Flag<String> backgroundColorFlag = visitor.getFlag("backgroundColor", "green");
Flag<String> btnColorFlag = visitor.getFlag("btnColor", "red, red, blue");
Flag<Number> backgroundColorFlag = visitor.getFlag("backgroundSize", "(Hello world)!");
Flag<Boolean> backgroundColorFlag = visitor.getFlag("showBackground", true);
Flag<String> backgroundColorFlag = visitor.getFlag("backgroundColor", "green");
Flag<Boolean> backgroundColorFlag = visitor.getFlag(showBackground, true);
Flag<String> backgroundColorFlag = visitor.getFlag(backgroundColor, "green");';
my $regex = qr/\.getFlag[(](?:\s*(?:\s*["'](.*)["']\s*,\s*(["'].*\s*[^"]*["']|[^)]*))\s*[)])?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}