import Foundation
let pattern = #"(?i)((face*book|(\bface.*book|face.*book.com\b/)).+\d)|(face.*book)|(\bface.*book|face.*book.com\b/.*id\S+\d)|(face.*book.com\b/.*id.\d+.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
facebook
face book
faceBook
Facebook
FaceBook.com
https://facebook.com/99402349034
facebook.com
facebook.com/
face
book
facebook.com
face-book.com
394023894230984
https://facebook.com/zuck
https://www.facebook.com/profile.php?id=100001533612613
https://m.facebook.com/ChrisHughes
facebook.com/id=xkdjfksjdflkdjfk
https://www.facebook.com/profile.php?100001533612613
https://www.facebook.com/profile.php?id=1d00001533612613
https://www.facebook.com/akld20322k332
https://www.facebook.com/profile.php?id=100001533612613
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)