re = /(?i)((face*book|(\bface.*book|face.*book.com\b\/)).+\d)|(face.*book)|(\bface.*book|face.*book.com\b\/.*id\S+\d)|(face.*book.com\b\/.*id.\d+.*)/m
str = 'facebook
face book
faceBook
Facebook
FaceBook.com
https://facebook.com/99402349034
facebook.com
facebook.com/
face
book
facebook.com
face-book.com
394023894230984
https://facebook.com/zuck
https://www.facebook.com/profile.php?id=100001533612613
https://m.facebook.com/ChrisHughes
facebook.com/id=xkdjfksjdflkdjfk
https://www.facebook.com/profile.php?100001533612613
https://www.facebook.com/profile.php?id=1d00001533612613
https://www.facebook.com/akld20322k332
https://www.facebook.com/profile.php?id=100001533612613
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end