import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)((face*book|(\\bface.*book|face.*book.com\\b/)).+\\d)|(face.*book)|(\\bface.*book|face.*book.com\\b/.*id\\S+\\d)|(face.*book.com\\b/.*id.\\d+.*)";
final String string = "facebook\n"
+ "face book\n"
+ "faceBook\n"
+ "Facebook\n"
+ "FaceBook.com\n"
+ "https://facebook.com/99402349034\n"
+ "facebook.com\n"
+ "facebook.com/\n"
+ "face\n"
+ "book\n"
+ "facebook.com\n"
+ "face-book.com\n"
+ "394023894230984\n"
+ "https://facebook.com/zuck\n"
+ "https://www.facebook.com/profile.php?id=100001533612613\n"
+ "https://m.facebook.com/ChrisHughes\n"
+ "facebook.com/id=xkdjfksjdflkdjfk\n"
+ "https://www.facebook.com/profile.php?100001533612613\n"
+ "https://www.facebook.com/profile.php?id=1d00001533612613\n"
+ "https://www.facebook.com/akld20322k332\n"
+ "https://www.facebook.com/profile.php?id=100001533612613\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}