# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)((face*book|(\bface.*book|face.*book.com\b/)).+\d)|(face.*book)|(\bface.*book|face.*book.com\b/.*id\S+\d)|(face.*book.com\b/.*id.\d+.*)"
test_str = ("facebook\n"
"face book\n"
"faceBook\n"
"Facebook\n"
"FaceBook.com\n"
"https://facebook.com/99402349034\n"
"facebook.com\n"
"facebook.com/\n"
"face\n"
"book\n"
"facebook.com\n"
"face-book.com\n"
"394023894230984\n"
"https://facebook.com/zuck\n"
"https://www.facebook.com/profile.php?id=100001533612613\n"
"https://m.facebook.com/ChrisHughes\n"
"facebook.com/id=xkdjfksjdflkdjfk\n"
"https://www.facebook.com/profile.php?100001533612613\n"
"https://www.facebook.com/profile.php?id=1d00001533612613\n"
"https://www.facebook.com/akld20322k332\n"
"https://www.facebook.com/profile.php?id=100001533612613\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.