re = /((лоял)\w*|(доволен)\D)|(устраивает)\D|(нет)\D|(нареканий)\D|(проблем)\D|(нравится)\D/i
str = 'лояльность
Лояльный
лояльности
лоялен
нареканий нет
доволен
сотрудничеством
устраивает
сотрудничество
работа
доставка
нарекания
проблемы'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end