import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((лоял)\\w*|(доволен)\\D)|(устраивает)\\D|(нет)\\D|(нареканий)\\D|(проблем)\\D|(нравится)\\D";
final String string = "лояльность\n"
+ "Лояльный\n"
+ "лояльности\n"
+ "лоялен\n"
+ "нареканий нет\n"
+ "доволен\n"
+ "сотрудничеством\n"
+ "устраивает\n"
+ "сотрудничество\n"
+ "работа\n\n"
+ "доставка\n"
+ "нарекания\n"
+ "проблемы";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}