$re = '/((лоял)\w*|(доволен)\D)|(устраивает)\D|(нет)\D|(нареканий)\D|(проблем)\D|(нравится)\D/i';
$str = 'лояльность
Лояльный
лояльности
лоялен
нареканий нет
доволен
сотрудничеством
устраивает
сотрудничество
работа
доставка
нарекания
проблемы';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);