const regex = new RegExp('((лоял)\\w*|(доволен)\\D)|(устраивает)\\D|(нет)\\D|(нареканий)\\D|(проблем)\\D|(нравится)\\D', 'ig')
const str = `лояльность
Лояльный
лояльности
лоялен
нареканий нет
доволен
сотрудничеством
устраивает
сотрудничество
работа
доставка
нарекания
проблемы`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}