re = /id : (?:[A-Za-z]+:)?\/{0,3}([0-9.\-A-Za-z]+)(?::(\d+))?(?:\/([^?#]*))?(?:\?([^#]*))?(?:#(.*))?, OS : ([\w]+)/m
str = 'id : http://17.196.32.47:5555, OS : MAC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end