$re = '/id : (?:[A-Za-z]+:)?\/{0,3}([0-9.\-A-Za-z]+)(?::(\d+))?(?:\/([^?#]*))?(?:\?([^#]*))?(?:#(.*))?, OS : ([\w]+)/m';
$str = 'id : http://17.196.32.47:5555, OS : MAC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);