package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)id : (?:[A-Za-z]+:)?\/{0,3}([0-9.\-A-Za-z]+)(?::(\d+))?(?:\/([^?#]*))?(?:\?([^#]*))?(?:#(.*))?, OS : ([\w]+)`)
var str = `id : http://17.196.32.47:5555, OS : MAC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}