using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id : (?:[A-Za-z]+:)?\/{0,3}([0-9.\-A-Za-z]+)(?::(\d+))?(?:\/([^?#]*))?(?:\?([^#]*))?(?:#(.*))?, OS : ([\w]+)";
string input = @"id : http://17.196.32.47:5555, OS : MAC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}